世帯年収500万前後の家庭にちょっとの潤いをお届け
Zabbix

ZABBIX 5.0.0 alpha2のインストールに失敗しました

失敗というか、断念です。

一応やったことを載せておきます。犠牲者が増えませんように。

 

注意:以降の作業はとても危険です。最悪サイトが吹っ飛ぶ恐れがあるので、良い子は眺めるだけにしてください

というか、レンタルサーバーではできないことのほうが多いはず。

 

①公式サイトからソースコードを取得

いきなりハードルが高いです。コピーしてコマンドドーン、ではないです。

なお、参考にしたのは↓です(日本語はない)

 

●WGETでサーバーからファイルを持ってくる

wget https://www.zabbix.com/downloads/nightly/pre-zabbix-5.0.0alpha2-1de494870a.tar.gz

 

●もってきたファイルを展開する

tar -zxvf pre-zabbix-5.0.0alpha2-1de494870a.tar.gz

 

●実行用ユーザとグループ、インストールフォルダを作る
(一応既存のものを残したかったので指定された名前をいじっている ←敗因の1つ)

groupadd --system zabbix5
useradd --system -g zabbix5 -d /usr/lib/zabbix -s
mkdir -m u=rwx,g=rwx,o= -p /usr/lib/zabbix5
chown zabbix5:zabbix5 /usr/lib/zabbix5

 

●データベースを作る

create database zabbix5;
create user zabbix5;
SET PASSWORD FOR zabbix5@localhost=PASSWORD('*********');

 

●configureを通す
(インストール前のチェックみたいなもの)

./configure --enable-server --enable-
agent --with-mysql --with-net-snmp --with-libcurl --with-libxml2

 

エラる

configure: error: MySQL library not found

これについては mysql-devel mysql-shared が入っていないことが原因だった。インストールして進める

 

またエラる

configure: error: Invalid Net-SNMP directory – unable to find net-snmp-config

これは net-snmp-devel をインストールして解決。そろそろいやになってきている

 

そして当然のようにまたエラる

configure: error: Unable to use libevent (libevent check failed)

libevent-devel を入れて対応。ちなみに朝から初めてこの時点で昼過ぎ。

 

configure: error: Curl library not found

自分の辛抱強さに惚れる。yum install libcurl-devel

 

 

そしてめでたく事前チェックをクリアするとこれが出てくる
(そのまま貼り付けるとたぶん崩れるので画像で)

 

 

 

●続いてインストール作業

make install

以降切ったり貼ったり、足したり削ったりを延々と繰り返す。

口を開けて見守る僕47歳。

 

そしてしばらくして唐突に終わる。

エラーは出ていないので問題はなさそう。続いてはWEBに移る

 

WEB表示がおかしい

 

 

 

 

 

CSSが読めていない。いきなりやばそうな雰囲気が漂う。

 

ちなみに正しい場合は↓のような画面が出るはず。

 

 

忘れていたが、最初はこれが出ていた

Minimum required PHP version is 7.2.0.

うちのサーバのPHPは7.1。5.0は7.2以上じゃないとだめらしい。

 

さくっとバージョンアップ ←

 

(注:PHPのバージョン変更は、動いてたものが動かなくなる代表格みたいなものなので、触らないほうがいいです)

yum install --enablerepo=remi,php72 phpMyAdmin.noarch
yum update --enablerepo=epel,remi-php72 php

 

即座に稼働中のサイトの状態を確認。問題ないようなので続行(おいおい)。

 

 

php.iniを見ても16になっている(たぶん7.2のDefaultなんだろう)

しかしZABBIXは10だとおっしゃる。

 

 

WordPressの.htaccessを確認。

php_value post_max_size 10M

 

 

お前か・・・・・。

 

 

 

と、ここまでやってふと外を見ると暗いじゃないか・・・・・

 

 

せっかくの日曜日がまるまるつぶれた格好。こうなれば皿まで喰ってやる

 

何度やってもDBに接続できない。そして飽きる僕

以降はこの画面とにらめっこ。さっぱり進まない。

 

 

 

 

 

 

 

 

何度やってもDBにはつながらない。

ここまできてようやく悟る

 

 

 

 

二重起動は簡単にはいかないな

 

 

 

 

 

恐らく既存のバージョンを消して、まっさらな状態でやればあるいは成功するかもしれないが、あまりにも作業が多すぎる。もういい。

※PID変えたりとかConfigの書き換えもやってみたけど、サーバとエージェントの起動で古いのが立ち上がってくるのでどうしようもなかった。上記エラーも、そもそもサーバーソフトウェアが起動していないことでのものと思われる

 

ということでこれから使わなかった、ゴミとなったファイル群を削除する予定。

 

 

おつかれさまでした。。。

 

 

教訓:素直に製品版がリリースされるまで待て

ABOUT ME
sampei
新しもの好きな40代おっさんです・・ 詳しくは こちら へ
Zabbix使いにおすすめ!
ZABBIXの本があるのをご存知ですか?

COMMENT

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください